Changing Priority of Amibroker and Velocity helps - Need confirmation from True data

Tarakeshwar NC shared this question 2 years ago
Answered

It appears that some heartbeat mechanism is used in Velocity. Whenever it goes out of sync (possibly due to load on the CPU) Amibroker does not update and velocity also stops getting data.

I tried changing the priority of Velocity (Truedata.Velocity.exe) to High and made the charting sofware to above normal. This seems to help a lot. Request Truedata cofirm if there are any other processes.. Also, if possible, assign and run the velocity at high priorirty without user intervention. (This means the tasks/threads should be created inside Truedata.Velocity.exe at high priority).

thanks

Best Answer
photo

Yes ! absolutely correct & Thank you for bringing this to everyone's notice.

Both Amibroker & Velocity need to be given Max priority, Full Access permissions in the Security & through any firewalls you may have along with Full Windows Admin rights.

The same can also be given to the Winros.exe file kept in the C:\Program Files (x86)\TrueData\TrueData Velocity 2.0 folder.

So this needs to be done for the following files (if you working with Amibroker):-


  • TrueData.Velocity2.exe
  • Winros.exe
  • Broker.exe (In amibroker Folder)

Right Click Each, then :-


  • Go To Properties > Compatability > Change Setting for All Users > Tick Run This Program As an Adminstrator > Click on Apply > OK > OK
  • Go To Property > Security > Edit > Make sure all the Allows Columns (Except Special Permissions) are ticked for All Users i.e. System, Administrators & Users (Click on Each one to see the Rights Allowed or Not - If not Ticked do that and save the same.
  • Also Full permission must be provided to all these 3 files by your firewall, antivirus & also Windows Firewall.

Other than that, if you use 200 symbols or more, you must get a good CPU (i5) and RAM >6 GB (preferable is 8GB).

Doing this will surely help your data flow.

Comments (3)

photo
1

Yes ! absolutely correct & Thank you for bringing this to everyone's notice.

Both Amibroker & Velocity need to be given Max priority, Full Access permissions in the Security & through any firewalls you may have along with Full Windows Admin rights.

The same can also be given to the Winros.exe file kept in the C:\Program Files (x86)\TrueData\TrueData Velocity 2.0 folder.

So this needs to be done for the following files (if you working with Amibroker):-


  • TrueData.Velocity2.exe
  • Winros.exe
  • Broker.exe (In amibroker Folder)

Right Click Each, then :-


  • Go To Properties > Compatability > Change Setting for All Users > Tick Run This Program As an Adminstrator > Click on Apply > OK > OK
  • Go To Property > Security > Edit > Make sure all the Allows Columns (Except Special Permissions) are ticked for All Users i.e. System, Administrators & Users (Click on Each one to see the Rights Allowed or Not - If not Ticked do that and save the same.
  • Also Full permission must be provided to all these 3 files by your firewall, antivirus & also Windows Firewall.

Other than that, if you use 200 symbols or more, you must get a good CPU (i5) and RAM >6 GB (preferable is 8GB).

Doing this will surely help your data flow.

photo
2

I found a way to set the priority using a batch file.


Create a .bat file (using notepad) with following content:


@echo off

wmic process where name="TrueData.Velocity2.exe" CALL setpriority "High Priority"

wmic process where name="Broker.exe" CALL setpriority "Above Normal"


After running the amibroker, run the above batch file as administrator. This sets the Priority appropriately.

photo
1

Thank you for this feedback !